HOT POTATOES
ACTIVITY-MAKING SOFTWARE

Hot Potatoes is a robust set of classroom activity tools that teachers can use to construct quizzes, cloze
or matching activities, and crossword puzzles. Hot Potatoes is an open-source software program that
can be downloaded here.

Hot Potatoes, like any technology used for the first time, can seem overwhelming. However, it only
takes a little practice to get comfortable with the basics. Once these basics are discovered, begin to try
the more advanced features shown at the end of this week’s Teacher’s Corner. Not everything needs to
be learned at once so don’t rush and don’t panic!

What makes Hot Potatoes a valuable tool in a technology toolkit is that the files created by the software
are simple .htm, or webpage, files. This means the files can be placed on computers in a lab, emailed to
and from students, added to course management systems such as Moodle, or printed out and given to
students as worksheets. Hot Potatoes can fit the realities of the classroom no matter the technology
infrastructure.

The basic layout of Hot Potatoes is enough to work in many classroom situations; however the software
can be extended far beyond its initial capabilities with audio, images, and video.

In this week’s Teacher’s Corner, we look at ways to use Hot Potatoes to make basic activities. The first
set of ideas below will offer a basic tutorial on the JQuiz feature of Hot Potatoes. Once this has been
mastered it is easy to transfer the knowledge over to the other features of Hot Potatoes such as JCloze,
and JMatch. While each creates unique activities, the design and layout of the software is the same.

After some practice with the basics of Hot Potatoes, consider adding images, audio, or video to your
activities. The second set of instructions below show how to use some simple HTML code to breathe life
into your activities through multimedia. Hot Potatoes is far more robust than what can be shown in this
tutorial, so it is important to play and experiment with all the settings. Be sure to have fun!

The Hot Potatoes suite is a set of six authoring tools that allows you to create different types of
interactive quizzes. The quizzes are viewed using a web browser. Each program can produce a different
type of quiz:

* JCloze —is used to make gap-fill or cloze exercises.

* JCross —is used to make crossword exercises.

* JMatch —is used to create matching exercises.

* JMix —is used to make jumble exercises.

* JQuiz —is a tool for making question-based exercises. Each quiz can consist of an unlimited

number of questions.
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For these instructions, JQuiz will be used as an example. JQuiz can feature multiple-choice questions and
short-answer questions. Quizzes can also feature a mixture of multiple choice and short answer known
as a hybrid question; questions can also be designed to allow students to select multiple answers.

The basic construction for JQuiz is:

[®]JQuiz [Untitled) 6 (= =3
File Edit Insert Manage Questions Options Help
aecHB R BHE®HE® B | 2
1 Title ] Name Your Quiz
Q|1 ] [What is the simple past tense of eat? - [Multlple-chmce Ll
2 - Weighting: [100 [
: 3 Answers 4 Feedback 5 Settings
Eated - Try again! Eat is not a regular verb. 4 [ Acceptas correct
A
0 %1 % correct
Eaten - Try again. This is the 4 [ Acceptas correct
B
0 %] % correct
Ate - Great job! You did your homework. + [ Acceptas correct
(o
100 |%| % correct
Ated - Try again! And be sure to study more ~ [ Acceptas corect
D
0 41 % correct
Confia: enalishé.cfa

1. Title — This is where to place the name of your quiz.
Qi# - This block is where questions can be added to the quiz. To scroll through the questions that
have been added, select the up and down arrows located next to the question number.

3. Answers — In the blocks below Answer are where the answers to the question are added. These
can be single words or entire paragraphs depending on the needs of the activity.

4. Feedback — Each answer can be given specific feedback that can specify why that answer is
correct or incorrect.

5. Settings — Under Settings, conditions can be set for each answer. For JQuiz to properly work, at
least one must have the Accept as Correct box checked.

6. Menu — The top row of buttons in Hot Potatoes is the basic commands for the software such as
file, edit, and insert. These commands are similar to those found in more common programs
such as Microsoft Word.

1. Begin by opening the software. For this example JQuiz will be used. Once opened, the software
will display the screen shown above.
2. Questions and answers can be added to the boxes shown as in the image above. Once questions
and answers have been added, save the file by clicking on File -> Save As
a. This save feature will produce a .jgz file. This is the working file that should only be
used to create the activity and should not be shared with students.
3. Once the JQuiz activity is complete it can be published as an .htm file for classroom use.
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4. To create the .htm file, click on File -> Create Web Page -> Standard Format

Lre)

‘2 New Ctrl+N
& Open Ctrl+0
H save Ctrl+S
B save As
<7 Add Reading Text Ctrl+R
£7 Add Metadata Ctrl+M
+ Append File
¥ Standard Format 6 ”ﬁ
1Z Create Zip Package F7
% Create SCORM 1.2 Package  F8
& Export for Printing Ctrl+P
4 Export for WebCT
HPExample.jgz
video.jqz
video.jqz
verbs.jqz
traceljgz
¥ Exit Ctrl+Q

5. At the basic level this is the scale of Hot Potatoes and much of the interface is similar to more
familiar software such as Microsoft Word. If you can copy and paste in Word, much of the
interface of Hot Potatoes will feel familiar.

6. With this brief overview, it is best to begin by making three or four activities using just the basic
structure and format of the software. Just keep in mind these basics:

a. Hot Potatoes saves two files:
i. .jgzfile — This is the working file to be used when making the activity. Each
piece of Hot Potatoes has its own file format (.jcl for Jcloze, .jmt for Jmatch)
ii. .htm —This is the activity file that should be provided to students. This file is
produced to look like a web page and can be opened with a browser (such
as Internet Explorer, Chrome, or Firefox).
b. Stay organized — Create a folder for each activity and save both the .jgz and .htm file
in the same folder. This will make it easier to find each activity.
c. After some time experimenting with the software, click on Options -> Configure
Output in the menu bar.
i. The Configure Output panel allows for the material to be customized such
as changing colors, changing texts, and adding additional instructions or
information.

Once you have the basics of Hot Potatoes, it is easy to branch out to more sophisticated activities. The
key is to take your time, play with all the available options, and allow for failure. While the below
instructions can seem very technical, it breaks down to three basic pieces of computer code. With only
these three pieces of code, a wide variety of activities can be made.

What is HTML?

Hyper Text Markup Language is the language that makes web pages possible. It works by containing
instructions within a set of < > brackets. These brackets tell the computer that the information inside
them is a set of instructions. For example a word in bold in HTML looks like this: <b>Hot Potatoes</b>. If
this were placed on a webpage all the reader would see is Hot Potatoes.
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Embedding Code into Hot Potatoes
A great place to practice embedding code into Hot Potatoes is with an image.
1. Begin by creating a new Hot Potatoes activity. Like the example above, a JQuiz is a good place to
practice.
2. After starting a new activity, be sure to save it first. This will create a working .jgz file of the
activity. Be sure to save the file in its own folder.
3. To embed an image into the activity, the HTML image code is needed:

a. <img src="cat.jpg" alt="Cat" style="width:304px;height:228px;">

b. What is important to remember with HTML code is that text appearing between the
“quotations” can be changed and the code will still work. For example in the code above
="width:304px;height:228px;" can be changed to ="width:500px;height:500px;" and the
code will run with a new image size.

c. Important: If you use an image saved locally (on the computer), keep it in the same
folder as the Hot Potatoes activity. If it is not in the same folder, the Hot Potatoes
activity will not find the image, and it will not appear in the activity.

4. By adding the code into the question text block, the image appears as part of the question.

a. Remember — the final activity will read everything within the < > as instructions.

aecHBE 8 x bR | BEATHE®R B | 2
Title Animal Vocabulary
Q‘»] j What is the name of this animal? -
Y| | <img src="cat jpg" alt="cat" style="width:304px;height:228px;"> -

5. After the code has been inserted and the .htm file produced, the image will be displayed in the

activity.

What is the name of this animal?

A ;IDDQ
B2 |cat
¢ _2 |Lin
D2 |Bid
6. If the picture is too large or too small, the size can be changed by adjusting the width and height.
a. For practice, change the numbers in the "width:304px;height:228px;" in the activity.
Save the file and then change the width and height numbers. See how the image
changes size.
7. This code is extremely flexible and can be used to include images from the internet as well.
a. For example: Let’s start with the code
<img src="cat.jpg" alt="Cat" style="width:304px;height:228px;"> The cat.jpg can be
replaced with the web address of an image.

americanenglish.state.gov




i. Try replacing cat.jpg with
http://americanenglish.state.gov/files/ae/styles/adaptive/public/frf_images/
trace-480x350_0.jpg?itok=CUjWfI36

ii. This will instruct the Hot Potatoes activity to visit that particular webpage and
add the image to the activity.

8. Try adding images to a Hot Potatoes activity to test the ability of the code. If mistakes are made,
just revert back to the HTML code above and try again! It is important to play with these
features to fully understand what is possible. Just remember:

a. The HTML code for images can be placed in any of the Hot Potatoes text boxes. Try
adding images to individual answers or even the feedback boxes.

b. If images display incorrectly, be sure the local file of the image is in the same folder as
the Hot Potatoes activity (.jgz) and .htm file. If an online image is being used, be sure the
web address for the image is correct.

1. Videos can also be added to Hot Potatoes but new code is needed:
a. <iframe width="560" height="315" src="https://www.youtube.com/embed/mxg-KTJY-
RA" frameborder="0" allowfullscreen></iframe>
2. The code above links to a video in the videogame Trace Effects. Try copying and pasting this
code into a new Hot Potatoes activity.
a. Remember —the web address for any video online can be used to replace the web
address in bold above.
3. Using this code can allow students to view a video online and then answer questions related to
the video all without having to change web pages.
a. Remember — if using an online video in the Hot Potatoes activity, the computers the
students use to complete the activity will require Internet access.
4. Again, if mistakes are made, just revert back to the HTML code above and try again! It is
important to play with these features to fully understand what is possible.

1. Using the code <embed src="audio.mp3"> audio can be placed into an activity in the same way
images and video can be added.
2. This code allows for the addition of locally created audio. This audio can be recorded on a
desktop computer or phone using recording software such as Audactiy.
a. Remember —if using locally created audio, be sure that it is saved in the same folder as
the Hot Potatoes activity.
b. For more information on using Audacity to create audio recordings, check back later this
month for Week 3 of the September Teacher’s Corner.
3. This code can also be used to add online audio materials into the Hot Potatoes activity. To add
online materials just replace audio.mp3 with the web address of the audio.
a. Remember — when using online audio, be sure to copy/paste the URL which will begin
with http://
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The above material may seem overwhelming at first, but don’t get disheartened. Any new technology
takes time and should not be learned through reading alone. As with any skill, technology fits well with a
learn-by-doing approach. This week’s Teacher’s Corner should be read step-by-step at the same time
activities are made in Hot Potatoes. Using this approach will show how simple these steps can be. Just

remember: approach learning new technology with a playful attitude, save often, and if everything fails
it is always okay to begin again!
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